Resolved
Major Outage

Started
January 10, 2023 at 10:17 AM
Status
Resolved after 10 minutes

Impact

Major outage
Affected
Website
  • Resolved
    January 10, 2023 at 10:27 AM

    We just resolved the issue!

  • Investigating
    January 10, 2023 at 10:17 AM

    We're currently investigating a test issue with this service