Resolved
Major Outage

Started
January 16, 2023 at 7:58 AM
Status
Resolved after 10 minutes

Impact

Major outage
Affected
Website
  • Resolved
    January 16, 2023 at 8:08 AM

    We just resolved the issue!

  • Investigating
    January 16, 2023 at 7:58 AM

    We're currently investigating an issue with this service